IPImen ، Firewall ، NGFirewall-UTM، آیپی ایمن، فایروال ایرانی ، فایروال بومی، یوتی ام بومی، یوتی ام ایرانی، فایروال نسل بعدی ایرانی، فایروال نسل بعدی بومی

Ivory Search WordPress

کلمات رایج امنیت شبکه و فناوری اطلاعات IPImen

به خطر افتادن بیش از 60 هزار سایت در پی آسیب پذیری XSS وردپرس

 

takian.ir wordpress XSS vulnerability

به گزارش لیتست هکینگ نیوز، یک آسیب پذیری جدی XSS در افزونه جستجوی وردپرس Ivory مشاهده شده است. سوء استفاده از این آسیب پذیری، به یک مهاجم سایبری می تواند امکان و اجازه اجرای کدهای مخرب در وب سایت هدف را بدهد. با توجه به تعداد نصب های فعال این افزونه، آسیب پذیری ذکر شده به صورت بالقوه بیش از 60،000 وب سایت را به خطر انداخته است.

 آسیب پذیری پلاگین جستجویIvory وردپرس

 محققان تیم آستارا سکیوریتی اینتلیجنس، آسیب پذیری اشاره شده را در XSS یا Cross-site Scripting، در پلاگین جستجوی Ivory وردپرس کشف کرده اند.

آسیب پذیری های XSS کشف شده بر روی برنامه های تحت وب تأثیر مخرب می گذارد و به مهاجم اجازه می دهند تا کدهای مخرب را در پروفایل ها و شناسه های کاربرها اجرا کند. به عنوان مثال، هنگام بازدید کاربر از صفحه وب آلوده، ممکن است یک کد دستوری مخرب اجرا شود.

آنطور که آنها در مطلب خود توضیح داده اند، تیم تحت هدایت جینسون وارگش یک مورد بررسی اعتبار نامناسب در این افزونه پیدا کردند. وارگش در توضیح این مشکل می افزاید:

"یک جز مولفه خاص در صفحه تنظیمات افزونه جستجوی Ivory وردپرس به درستی تأیید نشده است که به متعاقب آن، امکان اجرای کد مخرب جاوا اسکریپت را امکان پذیر می نماید".

محققان آن را یک اشکال با سطح خطر متوسط ​اعلام و تعیین کرده اند که به مهاجم اجازه می دهد "اقدامات مخرب" را در وب سایت هدف انجام دهد.

بروزرسانی اعمال شده

تیم آسترا سکیوریتی، در 28 ماه مارس سال 2021 این آسیب پذیری که بر پلاگین جستجوی Ivory وردپرس نسخه 4.6.0 به پایین تأثیر گذاشته است را کشف کرده اند. متعاقبا این تیم با توسعه دهندگان پلاگین ارتباط گرفته تا اشکال را در همان روز گزارش کنند.

در پاسخ نیز تیم پلاگین به سرعت برای رفع این آسیب پذیری اقدام کردند و در تاریخ 30 ماه مارس سال 2021، یک بروزرسانی را جهت رفع این اشکال در نسخه 4.6.1 منتشر کردند. آنها همچنین رفع اشکال موجود در لاگ تغییرات در صفحه پلاگین را تأیید کرده اند.

نسخه فعلی افزونه جستجوی Ivory ، نسخه 4.6.2 است. بنابراین همه کاربران این افزونه باید از بروزرسانی وب سایت های خود با نسخه 4.6.1 به بالا اطمینان حاصل کنند تا از هرگونه آسیب و به خطر افتادن سایت های خود و تبعات آن، ایمن بمانند.

به تازگی نیز چندین آسیب پذیری XSS که بر پلاگین Elementor تأثیر می گذارند نیز مورد توجه قرار گرفته اند. این اشکالات با توجه به طیف گسترده میزان نصب در سطح جهان (بیش از 7 میلیون) ، تأثیر شدیدتر و مخرب تری نیز خواهد داشت. از این رو، بدینوسیله شرکت توسعه امن کیان (تاکیان) به همه کاربران وردپرس یادآوری می کند که هنگام بروزرسانی وب سایت های خود، حتما از رفع این مشکل نیز اطمینان حاصل کنند. همچنین لازم است که کاربران به طور ویژه نسبت به بروزرسانی ماژول Elementor و Elementor Plus نیز اقدام نمایند.